WiFi with SamplerBox.img

J
John posted Apr 12, 05:35:

Has anyone been successful at getting the onboard wifi (wlan0) working with the SamperBox image?
How?
Any added lag?
How do we measure lag?

Current working awesome: RPi3+2uSD+UMX490+UCA222+KRKrocket5+SonySub+5VwallPS
Goal: RPi0w based USB to XLR (MIDI-PA dongle)

A
AlexM posted Apr 13, 02:51:

I've actually been working on this over the last few days! It's given me a lot of grief that's for sure

Hopefully I don't miss any steps here, but here goes... in the console input:

mount -o remount,rw / # remount as read-write
apt-get -y install wpasupplicant dhcpcd firmware-brcm80211 # install network and firmware packages
mkdir /etc/wpa_supplicant/
touch /etc/wpa_supplicant/wpa_supplicant.conf # for some reason doesn't exist as it should do
wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf # start wpa_supplicant service
dhcpcd wlan0 # assign IP address

Edit your wpa_supplicant.conf to include your network network (nano /etc/wpa_supplicant/wpa_supplicant.conf):

ctrl_interface=/run/wpa_supplicant GROUP=netdev
update_config=1

network{
ssid="YOUR NETWORK NAME"
psk="YOUR NETWORK PASSWORD"
}

CTRL-X and Y to save

Now let's get samplerbox.py to assign an IP address on startup (probably a better way to do this!). Open: nano /root/SamplerBox/samplerbox.py and under all the initial import statements add:

import
os.system('dhcpcd wlan0')

CTRL-X and Y to save

That should do it. If anyone has a better way of getting on-board wifi up and running, please share! Seems strange that we have to do this since the latest .img uses the latest Raspbian (Jessie) sources.

J
John posted Apr 13, 16:58:

AlexM,
YOUR AWESOME. I was stuck at "install network and firmware packages" Thanks...

There is a sintax error in your post and I had to issue a reboot 2x to get things going but BIG TY!

RE-POSTING with what worked for me

mount -o remount,rw /
apt-get -y install wpasupplicant dhcpcd firmware-brcm80211

NOTE: The wpa_supplicant folder was already there for me

reboot
mount -o remount,rw /
wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
iwlist wlan0 scan

Edit your wpa_supplicant.conf to include your network network (nano /etc/wpa_supplicant/wpa_supplicant.conf):

ctrl_interface=/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="YOUR NETWORK NAME"
psk="YOUR NETWORK PASSWORD"
}

CTRL-X and Y to save

reboot
mount -o remount,rw /
wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
dhcpcd wlan0

WORKS

I'm having to start it up manually now, but there has got to be way to clean it up

A
AlexM posted Apr 14, 10:53:

Great! Good to know that worked. I'm still not sure why the wifi firmware package (firmware-brcm80211) isn't installed by default by Raspbian Jessie. If anyone can enlighten us, please share!

A couple of improvements:

  • apt-get install the package dhcpcd5 instead of dhcpcd
  • systemctl enable wpa_supplicant to start the wpa_supplicant service
  • no need to call wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf or dhcpcd wlan0 (can ignore the lines i suggest adding in the samplerbox.py)

The next SamplerBox release will have this sorted ;)

C
Cedric posted Jul 6, 09:33:

Hi,

I have followed your instructions and it succeed at last.
Anyway, Wifi does not start automatically.
Is there a way to automatically start Wifi ?

you wrote "The next SamplerBox release will have this sorted ;)"
--> when the new version will be released ?

Thank you.

...

  (not published)
  I want to post as guest
 

Post