Can't get it to work (no sound and media)

Nick posted Mar 20 '16, 16:29:

Hi everyone,

I have an iRig USB keyboard, a USB DAC, and a USB stick with the basic Mellotron and Piano samples connected to the Raspberry Pi 2B. However, I can get no sound. I tried chaning the AUDIO_DEVICE_ID line in but it doesn't change anything, and I also don't have any files in the /media/ folder even though my usb is plugged in. I tried to manually copy the Mellotron folder to the /media/ folder to see if it would work, but still no sound.

I looked through all the forum posts, and even though some people had a similar issue I didn't find a solution.

Any help would be greatly appreciated!

Ptitleon posted Mar 20 '16, 20:51:

Hello, try with a recent USB stick, i had problems with an old one. And after if its doesnt work, you need to connect a console to the Pi: Hdmi screen and keybord or connection via putty on your computer to observe what happend... good luck

Nick posted Mar 21 '16, 09:19:

I've tried another USB stick but it makes no difference. I'll try a third one. I'm already connected via SSH/Putty, and the program itself is running (checking with the command that shows up on startup). I don't know what specific codes to look up to check for any errors.
Thanks for the reply

SPFY posted Mar 21 '16, 11:22:

Have you tried with the samples put directly on the SD card (in root) ? Does it work ?

Nick posted Mar 21 '16, 16:16:

I put a folder with samples named "0 Mellotron MkII Flute" in the /root/ directory, and set SAMPLES_DIR = "/root/" , but I still get nothing.

Nick posted Mar 21 '16, 16:39:

Same if I put it in /root/SamplerBox/ and SAMPLES_DIR = "/root/Samplerbox". Also tried another midi keyboard but no change. Is there a way to check if my DAC is being used correctly? The problem might lie there

SPFY posted Mar 21 '16, 17:25:

It's a long shot but maybe try with two folders, one "0 saw" and the other "1 Mellotron" (for example). Sometimes it works (cf
Also, what happens when you input ls /media (if the samples are there) ? (cf :
Finally, have you tried your config using the portable samplebox ( ? This might help pinpoint the problem.

Nick posted Mar 21 '16, 17:52:

Thanks for your help, I ran the "systemcl status samplerbox" line again to check for problems and this time I had a failure. Turns out that it was a naming mistake in the file: I had put true instead of True with a capital. At the moment it works when running the samples straight from the /SamplerBox folder, which is great news.

However, I still get nothing from my USB stick. I ran the ls/media code but I got no results from 2 different usb sticks. Since I'm working on an enclosed build it would be quite handy to be able to use a usb. Any suggestions? I noticed there were more people with the problem but didn't find a definitive solution.

Much thanks for the help already, I appreciate it.

Nick posted Mar 21 '16, 18:02:

UPDATE: just checked via SSH and I do see my sample folders now in /media, and it seems to work now with SAMPLES_DIR = "/media" ! It does work with only 1 of my usb sticks, is there any known reason for this? I would've preffered using my other one, but if there is no solution then I'll have to live with it.

SPFY posted Mar 21 '16, 21:32:

As you've probably seen, there are reports on the forum of some sticks working better than others, unfortunately, like the DACs. I don't know that there any way to make a stick more compatible.


  (not published)
  I want to post as guest