Sudo command not found (SSH)

SPFY posted Mar 21 '16, 11:20:

I'm trying to SSH into the raspberry but I can't get to access the raspi-config screen. The Pi says sudo command not found, and if I try without sudo it says raspi-config command not found.
How did you manage to SSH into the Pi ?
I'm using the recommended install and the program runs fine otherwise.
Thanks !

Nick posted Mar 21 '16, 16:22:

I had kind of the same issue yesterday, what worked for me to access all files was typing in the command "mount -o remount,rw /" after logging into the raspberry pi.

SPFY posted Mar 21 '16, 21:28:

Unfortunately that doesn't work, I still get sudo command not found or raspi-config not found even when in rw mode.

Nick posted Mar 21 '16, 21:41:

Why exactly are you trying to access the raspi-config?

SPFY posted Mar 21 '16, 22:41:

To SSH into the samplerbox : is SSH enabled by default ?
I'm trying to SSH by direct Ethernet connection but I can't reach the Pi. Following this tutorial , I'm unable even to Ping the Pc from mi Pi and vice-versa.
I don't know a lot about network connections, I'm stating to suspect this might be an eth0 problem in samplerbox ? Do you know about this sort of problems ?
(I can't connect to both a monitor and a router at the same time).

SPFY posted Mar 21 '16, 23:23:

On second thought, I'm rather starting to suspect the Ethernet cable might be dead. I tried to connect the Pi to the router with it and it didn't work either (I couldn't see the Pi in the connected devices on the router page).
I thought the cable would work since it's new, but I'm starting to have more and more doubts. I'll try with another cable and / or wireless dongle tomorrow if I find some.

SPFY posted Mar 23 '16, 18:21:

It was indeed Sa RJ45 cable problem. Thanks for your help.


  (not published)
  I want to post as guest