Dorgangrinder posted Mar 24 '16, 13:11:

Has anyone yet used the sampler samples with RaspberryPi3/sonicpi ?
Any advice welcome

Martin posted Mar 25 '16, 08:47:

I've tried. It doesn't load. If anyone can provide a way we can get this working, it'd be much appreciated.

Rakotomanga Goda posted Mar 25 '16, 11:07:

it will be great

Dorgangrinder posted Mar 27 '16, 12:35:

Thank you for your responses. I am wondering if Samplerbox will itself use the Pi3 in it's own box? Are there any intentions in the near future ?

Martin posted Apr 7 '16, 19:47:

Hey all, further to my original post I decided to give it a shot myself. I can confirm the image doesn't work on rpi3, but installing it manually does - There are various changes you'll need to make to the samplerbox.py in order to get it working though. For example, the /media mount isn't automatically created, the display() function is referencing a dependency that doesn't exist (though I did install all dependencies stated in the git repo) and the samplerbox obviously won't automatically start.

If anyone wants more info, please let me know.

Martin posted Apr 7 '16, 20:13:

Again, further to the previous post. I've now got my pi3 all up and running. If anyone's interested, I can either help or I can provide the image of my sd card.

rakoto posted Apr 8 '16, 10:51:

Hi Martin

I'm interested with the SD card Image!!!

Pragma posted Apr 9 '16, 16:11:

Yeah, having the sd image would be fantastic! I've just bought an RPi3 to use as a samplerbox,never used one before and it was driving me crazy! The Rpi3 incompatibility explains also why my Alesis V49 leds don't light up when i connect the usb or that is another matter?

Dok posted Apr 9 '16, 16:39:

I too would love te RPi3 image please :)

Francesco posted Apr 11 '16, 14:33:

Hi martin, i have a Pi3 on the way..
can i have a link to the working image?


Erik posted Apr 11 '16, 15:21:

Yes, got a RP3 just for this. The image would be great. Thanks for all your effort!

Will posted Apr 13 '16, 17:15:

Hi Martin, if you could give some pointers and/or an image that would be amazing!

Jerome posted Apr 16 '16, 12:02:

Hello, I had the same issue. Finally with the image dowloaded on samplerbox.org, I changed 3things and succeeded to boot:

A- boot-delay passed from 0 to 1 (config.txt) => no change

B- replaced the kernel image with a recent one directly in boot partition => no change

C- I replace also the file star.elf in the boot partition : booting !

But, I am always stuck without any sound produced due to some configuration error...

Jerome posted Apr 16 '16, 12:06:

I have also an Alesis but a QX49. Pi3 simply doesn't seem to be able to power up this keyboard. I try to insert a powered usb-hub and now my keyboard can switch on its display...
I have always no sound even if I am able to play some WAV files with 'aplay' command.

Pragma posted Apr 17 '16, 01:21:

Hi Jerome, it was not a Raspberry/usb power problem because when i booted with Raspbian and connected the midi keyboard, it lighted up. So i think it is, at least for the V49, a Samplerbox issue with the RPi3. Thanks anyway!

Jerome posted Apr 18 '16, 21:07:

Hello Pragma,
For my QX49, It lighted up for ~1/4s then keyboard and pi3 switched off and finally pi3 rebooted, and the same as long as pi was powered...
What seems strange to me is that I would have thought the behaviour to be the same for both V49 and QX49.

Martin posted Apr 25 '16, 23:25:

Hi everyone, really sorry I didn't respond sooner. I didn't get any email alerts to tell me someone had replied! I'll see if I can pull the image off my rpi3 over the next few days and host it on my domain. :)

Erik posted Apr 27 '16, 17:28:

To install on a raspberry PI 3 is easy: Get SamplerBox image, copy to SD. Replace start.elf with a recent one (from latest Jessie Lite: download, unzip, open image and copy start.elf). This boots up and everything works great! I can load the SAW samples and they work with my setup

Except: only 128MB of memory available (use 'top' to check). Any idea how to get the 1 GB RAM there?

Erik posted Apr 27 '16, 18:16:

Okay found it!

Copy start.elf and fixup.dat from Jessie lite to boot.


Fully working ;)

Much better than creating the image from scratch, doing all the optimizing and making it read-only. The samplerbox image is great, fast and now working on the RP3.
6 sec startup time on the RP3

Jonathan posted May 4 '16, 06:31:

thanks for your guys work on this. Are any Pi3 users noticing any better performance, etc?

Jérôme posted Aug 22 '16, 14:48:

Hi erverybody,
Just to finalize my little story. I succeeded with orginial image + replacing the start.elf file of the boot directory by a recent one (the one of the last raspbian...).
My problems were coming from a USB-Hub that was not recognised or malfunctionning itself (I don't test it on a standard PC).
I need to connect my keyboard direcly to the PI3 USB (and powered by another power-supply, not directly by USB because crashing all).
And then, poor sound but some sound. Then, I tried with a very cheap USB DAC and all works fine now!

HansEhv posted Aug 22 '16, 23:29:

The PI is by nature not strong in power on USB and can malfunction because of that. If you have a strong adapter (say 1.5A with a thick cable) you can consider to add "max_usb_current=1" to config.txt.
Article https://www.hackster.io/idreams/boost-usb-current-in-raspberry-pi-a1531d shows ways to double the software limit on the USB ports power supply.
http://hackaday.com/2015/04/06/more-power-for-raspberry-pi-usb-ports/ is an in-depth article on the same subject and gives the hardware solution to get to 4 times more power.

Joseph posted Aug 29 '16, 02:30:

@Erik and others : it would be great if someone could run the image-making script from a RPi3 and upload the ISO file. See http://samplerbox.org/forum/172

Jérôme posted Sep 12 '16, 16:54:

I tried recently the GrandPiano and have no sound. I found it is due to memory management. So I tried the solution of Erik (see above 27th of april): Copy start.elf and fixup.dat from Jessie. So I add the fixup.dat from Jessie but still have memory problems with the big samples of GrandPiano.
I don't understand why... If Erik has any idea, I am still interested! ;-)
Thanks a lot!

Jérôme posted Sep 12 '16, 20:05:

I have tested a small version of GRandPiano: limited to 49 notes and 3 layers of velocities it then worked. The limit is near 128Mo for samples sizes. It correspond to Erik's issue (but solution not!).
If anyone has an idea, I promise to light a candle for him! :-)

Jérôme posted Sep 14 '16, 17:22:

Ok, in fact it works now with exact Erik's solution (pre-may version of the start.elf and fixut.dat).
But I still have some issues with the velocity layers. With the standard definition.txt of GrandPiano samples, I only have 2 (or maybe 3) layers accessible playing on my keyboard... I also tried to change the definition.txt to add more layers. Samples are loaded without any problems but when I play I only have the lowest and highest velocities, not the intermediate ones...

HansEhv posted Sep 18 '16, 01:41:

Hello Jerome,
You can also consider using Erik's accurate velocity solution, in which case you only need the velocity layers for getting other timbre.
It's also in my alternative implementation: http://homspace.xs4all.nl/homspace/samplerbox/


  (not published)
  I want to post as guest