Issue with Grand Piano wav on RP3

John posted Sep 20 '16, 22:53:

Hi All, got the basic image working with my 61 key usb keyboard on a RP3. No buttons or 7seg display yet. I can hear the saw sounds ok but when I put the 1 GrandPiano wav snippets onto a usb stick and plug it in, no sound at all?. Stick mounts fine under /media.

I also tried putting the GrandPiano wav in the /root/SamplerBox/ folder and nothing... Any ideas please?

Andy posted Sep 21 '16, 13:59:

Can you play the other sample sets? The GrandPiano set is the biggest one and it takes some time for me to load (15 sec).

John posted Sep 21 '16, 15:46:

Yes. The saw samples work fine. I'm toggling through the sample sets using the program + button on my keyboard. Anything above 0 doesn't work.

John posted Sep 21 '16, 23:21:

Problem was a dodgy usb flash stick. I used a new stick and it worked first time...

My new issue now is distortion on the grand piano notes. In the default setup on a RP3,every time I play a chord there is so much can I fix this please?

Joshua Rackstraw posted Oct 27 '16, 23:15:

I think i have some distortions too. Is yours volume related? I think mine is a software thing. It seems to happen pretty much at random.

AlexM posted Oct 28 '16, 02:21:

Sounds like either buffer or volume related. Try increasing the buffer size in the .py. There are instructions somewhere here on the forum on how to do that. We really need a real-time limiter don't we! :)

Dom posted Oct 28 '16, 11:42:

As for the dodgy USB: Here's a tip I got from HansEhv:
On your Pi, after logging (root/root) in and setting read-write (Mount -o remount,rw /), goto
nano /etc/fstab
edit the file from "SDA1" to "SDA", save and reboot. It varies from USB to USB wether the 1 is needed or not.

You always hear the SAW Sample, because it's implemented in the ISO itself (see Pi3 ISO Notes), so if the Pi can't Access the USB drive, it can only play the Saw Samples from the ISO. That's how you know, you need to change "SDA" to "SDA1" or vice versa.

Kev posted Nov 18 '16, 03:04:

How do you set it back to 'read only' when finished?

kev posted Nov 18 '16, 03:52:

I tried "mount -o remount,ro /"(without quotes)

But anyway... this should not effect the functionality.
I still cannot get anything but 0SAW.
tried different sd cards, adapters and flash usb sticks.
None of them work.

I have momentary switches between pins 6(Gnd)-11(Gp7) and 6(Gnd)-12(Gp8)
I can switch away and back to 0saw but no other sounds are emitted.
Is it necessary to have the multi segment LED connected in order to function?

AlexM posted Nov 18 '16, 08:22:

Hey Kev. Have you tried editing the file to define where the system should look for your sample sets? By default it looks in the SamplerBox root directory on the Pi's SD card. If you change it to /media/ it should look for sample sets on your usb stick. Be sure to prefix the folders numerically! eg 0Saw, 1Grand, 2AnotherInstrument etc

And no it isn't necessary to have any kind of display for it to work

kev posted Nov 18 '16, 16:17:

Thanks for the Fast reply Alex :D

I was directed to the file in the readme to check the locations pointed to.
The example given is "/media/" and this is also the default location already.
The samples are the free ones given here in the 'instruments' section.

I am using the samplerbox_20161114.img
the micro sd, usb(midi)keyboard and soundcard are all connected via a usb hub

Do I need to name the actual sd card "media" or some other name?
do you know any other locations my sd card might appear as?

kev posted Nov 20 '16, 16:09:

Hey guys,
I have been over the info here, on Alex, and Hans sites and I can still only get the saw.
There is mention of the difference between sda/sda1 being caused by the presence of a boot sector on my external SD.
Could I try adding or deleting this section to the SD then putting the samples on again?
how would I do this?
I have ordered a 7seg numeric display so I have at least some idea of where i am, or if the presets are moving at all but I still have been unsuccessful getting anything but the saw sound out :(

Benwa posted Nov 25 '16, 17:57:

I saw that my samole can be read only if my stick is connected before powering my pi3, maybe it s the same for you?


  (not published)
  I want to post as guest