PI2.1 No Sound

James Dover posted Oct 30 '16, 01:26:

Background: 10+ years with Linux and countless hours with linux sound (ALSA, JACK, etc...)


RPi 2.1 with PadKontrol (as MIDI controller), no DAC (audio out on stock Raspberry Pi), HDMI to monitor, USB stick with samples (Mellotron Flute sample library) and a QWERTY keyboard attached via usb.

Problem: No audio on MIDI trigger. Assigned note patches that exist in Mellotron sample library to pads in; sample library loaded without issue. No audio on MIDI event. See the following images to see what happens.

http://i.imgur.com/UentFfp.jpg (I've tried modifying AUDIO_DEVICE_ID with values 0-3 with the same result.)
http://i.imgur.com/rlh3wQL.jpg (python sound test)

Is the problem with the RPi DAC/audio out? If so, can anyone reccomend a DAC that I can purchase in the US (links to suggested DACs on samplerbox.org are in the UK) and is affordable( < 20$ ).

Samplerbox is the answer to multiple years of futzing with linux sound, really want to make this work, but can't get any output. Don't care if the output sounds like garbage right now, just want to get a signal out from a MIDI trigger to prove that the idea works. Thanks for your help!

HansEhv posted Oct 30 '16, 01:45:

Hi James,
Your first image shows "preset empty 0".
This means that it cannot find the /media files.
In other words: the usb stick with samples is not inserted or it is not recognized (or does not have a folder named "0 blahdieblahdieblah" with correctly named samples).
Check with lsblk how your stick is mounted and check the fstab.
Problems arise often because the usb sticks have different boot sectors and thus present themselves as SDA or SDA1. This has to be correct for your situation.

James Dover posted Oct 30 '16, 02:03:

Thanks for replying. I've loaded the samples successfully with the same result (no audio after MIDI trigger). Not close to the pi now, otherwise would attach screenshot. Thanks again!

Rob Cranfill posted Nov 8 '16, 02:32:


I don't know which SamplerBox image you used, but I had much better luck with my Pi2B and the "20160831" image (linked to here in the Forums), rather than the seemingly-more-official (on the downloads page) "20150618" one.



  (not published)
  I want to post as guest