No DMA platform data..

Max posted Oct 31 '16, 09:50:

Hello !
On this morning, after some huge struggle (24h hours to figure out i forgot the blank space in the folder names), i finally got my samplerbox to work, with the Pi 3 nude (usb keyboard and usb storage only).
Now, i'v plugged the switch and the display, and the pi doesn't boot propperly anymore, all i get is this line :
[8.669431] uart-pl011 3f201000 .uart: no DMA platform data

Any idea how to solve this ?

Max posted Nov 1 '16, 20:13:

I unplugged everything, except a HDMI screen, and i keep getting this error, despite the fact i remounted thé image on the sd.
That is very frustrating, because it worked fine, and this error seems to come from nowhere.
Please help !

Max posted Nov 2 '16, 13:44:

I wanted to change the configuration (to test if the error came from that), like said in FAQ#17, and i can't find the file and directory given in the answer, neither by exploring my SD in windows or by typing the command line directly in Samplerbox.
I'm getting a bit nervous about this project. :(

r.meurer posted Nov 17 '16, 17:07:

The very old Image from 2015 works fine for me but the new image 20161114 gives me the same message and of course NO SOUND :-( how can it be this works for other People? isn't Raspberry Pi = Raspberry Pi ?
I'm using Pi 2B as well Pi 3 both the same

r.meurer posted Nov 17 '16, 17:37:

WOW got it work. Using a MIDI Interface instead of the GPIO INPUT.
BUT why the old Version works but the new Images not? Is the GPIO Serial Input disabled now?

berth posted Feb 2 '20, 13:52:

on booting; i seem to get a similar eroor

samplerbox login: [ 6.7416591 random : unblocking pool is initialized
[6.773493] gpiomen-bcm2835 3f20000000.gpioen: gpiomen device opened.
[ 7.317544] uart-pl011 3f201000.uart: no dma platform data

how did anyone get round this? if it works with the 2015 image... can that still be found somewhere?

nobody posted Sep 24 '21, 00:41:

This is an ancient thread, but newer versions of Raspberry OS default to NO UART enabled.
You need to add a line to your /boot/config.txt file that says


  (not published)
  I want to post as guest