Still Not Playing anything but 0Saw default samples

kev posted Nov 21 '16, 17:45:

Ok, well another day of frustration, all my free hours into finding the commands to change directories SDA SDA1, editing to "/media/"as per the readme, swapped out numerous SD cards, flash sticks, re-formatted and tried again and even tried a powered external drive.

Hunted down older versions of the image, tried the image here:
again with every combination of drive I have, nothing.
All to no avail.

There must be some critical element I am missing, A step I am overlooking...

Really wanted to build my own solution but I'm now looking at these:

Less than the price of the pi3 alone. Anybody here tried one?
(there is also a second release which has rhythm patterns and a better screen built in, but is too busy on the options, also no usb samples are allowed (to maintain low latency)

HansEhv posted Nov 21 '16, 22:03:

Hi Kev,
When you have inserted your storage device in a usb port, can you do an "ls /media" command and do you see the anything listed and if so: are there your sample directories named like "1 name" (mind the space).
And if there is nothing at all to be seen, can you issue and "lsblk" command. There you can see how this particule usb storage device is mounted and whether or not the "/etc/fstab needs" to be adapted.

kev posted Nov 22 '16, 00:55:

lsblk command returns 4 items/blks:

USB confirmed as SDA, when I unplug this item disappears.

ls /media has no return just repeats

HansEhv posted Nov 22 '16, 08:20:

Hi Kevin,
So it sees your USB drive as SDA, but does not properly mount it. What's in your fstab now?
Mind if you change this, you need a restart.

kev posted Nov 23 '16, 01:05:

hey, thanks for the reply

So, changed fstab(was sda1) to some different things and again no luck :(

However, I accidentally left the pi ON while I was searching google for answers.
when I came back I smudged the keys out of habit before rebooting and a NON-Default sound came out!!

The Pi must of been hanging doing nothing for about 10 mins then displayed this message:
[54.381772]USB 1-1.2.2: 1:1: cannot get freq at ep 0x5
[54.381772]USB 1-1.2.2: 1:1: cannot get freq at ep 0x5

then it worked!
It does this every time, I just had to wait longer! so... Great to finally hear some sounds.
But unless the normal boot time is 10 mins+ (I hope not) I have some sort of issue elsewhere.
Is this normal?

AlexM posted Nov 23 '16, 02:15:

Something spooky is going on there Kev! Are you able to borrow someone's Pi? That might be easier said than done - but it'd be one way to confirm or rule out your Pi being defective. In any case, 10 minutes is definitely crazy - should be under 10 seconds!

Also, how are you formatting and writing the ISO to the SD? Perhaps something is going awry during this process (although probably unlikely)

That MidiPlus module is pretty cool for that price tag - although no where near as flexible as a SamplerBox. For starters you can't load up or manage your own sample sets, and the sounds you do have access to aren't wavs (at least I dont think they are).

kev posted Nov 23 '16, 03:43:

Just took a pizero from another project and gave it a try (Smaller sample sets only of course).
almost the same results, faster to boot. except there were WAY MORE warnings like this:
[54.381773972]USB 1-1.2.2: 1:1: cannot get freq at ep 0x5
[54.3819872]USB 1-1.2.2: 1:1: cannot get freq at ep 0x5
[54.38298241772]USB 1-1.2.2: 1:1: cannot get freq at ep 0x5
[54.38190842]USB 1-1.2.2: 1:1: cannot get freq at ep 0x5
etc etc.
and more everytime you switch bank

I am using SD Formatter
and then Win32DiskImager to create the flash/sd sticks

AlexM posted Nov 23 '16, 07:06:

Very strange!

Have you tried running the script from the command prompt?

sudo killall python
cd SamplerBox

There may be some python errors. Something to check in any case

Also, have you tried this release? This was the last one of Joseph's I tried:

HansEhv posted Nov 23 '16, 08:19:

I get the 'cannot get freq...' message from the midi interface. It doesn't hurt, but like Alex I'm surprised regarding the delay.

HansEhv posted Nov 23 '16, 09:31:

BTW, a more elegant way to stop the running samplerbox is 'systemctl stop samplerbox '.

Jon posted Nov 24 '16, 07:30:

I searched a bit and found some references to 'cannot get freq...' message here: I know they are talking about a webcam but perhaps you have a usb audio device attached? Worth a read anyway.

Are you able to try a different midi controller? I'm assuming its attached via usb (given these messages are coming from usb)?

I get the impression that midi-over-usb wasn't particularly standardized, so older controllers (like my m-audio/midiman oxygen) need drivers before they will work via USB.

You can check if your pi can play the default sample by logging in, cd to wherever the default samples are (can't recall the location now and I don't have the PI to hand) and picking a file and playing it. I think you can use 'aplay something.wav' (again command from memory).

Hope this helps,


kev posted Nov 24 '16, 19:49:

Yes I found the same, google yields little else but it does look like a usb issue.
I have Usb hub with m-audio keystudio usbmidi, Audio card, flash stick for the samples.
must be one of these, as the problem is the same on other pis:
so, either:

The usb hub
usb midi keyboard
usb audio card
Is causing this issue.

Hopefully the addition of the 7seg display will make this a little less painful to use but
This issue is way beyond me unfortunately, I will try and swap out some of these parts and see if there is any difference.

Otherwise I will likely put this project away and check back at a later date.
hopefully there will be some resolve for my issues in a revision down the line.
I would love to use the pizero without this freeze/delay as it is definitely functional when it finally loads.

HansEhv posted Nov 25 '16, 00:18:

But why use a hub if the pi has 4 usb ports and you're only using 3 usb devices?
You could eliminate the hub from your cause options with this.
Re the display: this does not give any debugging messages unless programmed by yourself.
I would go for simply starting the script from command line as suggested above. With some print statements for debugging it will get you going much faster than the display.

kev posted Nov 25 '16, 05:09:

I am an expert at plugging in different usb cables now!
I booted multiple times in multiple configurations and took a quick note of the times etc.
Got some results I thought I would share for others in the future.

My problem appears to have mostly been my USB HUB!?
Changed it out and the boot time has improved significantly.
Not sure how common it is, but 2 of my Micro SD cards seem to work sometimes yet other times simply refuse to be read. That's two problems sorted.

Pi3 now boots in around 14 seconds every time with my good flash stick using mini USB soundcard.
Using the onboard audiojack, the time is marginally better but doesn't sound as good to me(Maybe just volume, Fletcher munsen etc.)

For anyone who is interested:
The pizero boots in just over 25 seconds, This is fine for my purpose and my mini version of the project.

For my mini version of the project I will be using the zero with the 7seg led to keep it small.
there is a circuit available to add audio out via PWM0 and PWM1 as a carrier. I also plan to use a mini jack for the midi input ala korg et al.

I want to make this as small as possible so all the internal usb connectors will be dispensed with and directly wired.
Should probably get a reading on the current draw from the piZero vs the pi3 as well. I will update here when I do.

Thanks for all your help and suggestions guys :D

kev posted Nov 25 '16, 05:18:

Hans, Yea the hub was because the final intended project was for the zero.
I did eventually get the opportunity to go direct to the onboard USBs on a pi3 to cross check, and then eliminate the problem with the hub.
That unit is the main media centre in the family living room so I had limited time with it until today :)
The desire for a display was just so I could see if the bank was actually changing without the use of a monitor.

Thanks again for the help

AlexM posted Nov 25 '16, 06:04:

Phew! Glad you got there in the end!

Is the hub powered independently or via the pi? I'm using a powered hub (for testing only) with no dramas, though I have come across dodgy hubs in the past.

Very keen to see what you do with your piZero!

kev posted Nov 25 '16, 16:59:

Yea me too! :D
I will get on it and share some pictures as soon as my parts arrive.

It was non-powered hub, I think now... it is possibly usb 1.0...
I have switched it for the one my external drive was connected to the pc with.
transfers from my pc to my drive are now slower. but I have another on the way.

I am still getting the [54.381773972]USB 1-1.2.2: 1:1: cannot get freq at ep 0x5 error
Any way to find out what it is trying to do here?

HansEhv posted Nov 30 '16, 22:59:

I think it's midi hardware trying to sync.
I had it appearing continuously on a malfunctioning midi adapter. Yes indeed, a cheap chinese one ....


  (not published)
  I want to post as guest