PI4: Samples are not loaded when the program starts

A
Arthur posted Dec 5 '21, 01:47:

Hi there,
Yesterday I wrote the latest SamplerBox image on my PI4 and no samples are output from my SD card, but sounds of very poor quality (samples that are on the operating system microSD card as default?)

Only when I manually stop and start the program by commands:

"systemctl stop samplerbox
python /root/SamplerBox/samplerbox.py"

the samples will then be loaded correctly and played back.

I have made a workaround for the whole thing and have simply integrated these commands into the file (/etc/rc.local) so that the program is stopped and started when the operating system is booted. However, since the device has been switched on, the whole thing takes about 1:15 minutes until I can use the SamplerBox.

Does anyone here have an idea why my samples are not loading correctly from the start?

Best Regards
Arthur

A
Arthur posted Dec 5 '21, 14:05:

Today I integrated the new image on another card and another PI3 and have completely the same behavior!
Has the new image already worked correctly for somebody here in the forum?

J
Joseph posted Dec 6 '21, 16:07:

Hi Arthur

I just redid a full test from scratch:

  • I downloaded the latest image from website
  • I flashed the image to a microSD card with Rufus
  • I inserted the microSD card in a RPi4 (on the PCB: "Raspberry Pi 4 Model B / © Raspberry Pi 2018")
  • I plugged headphones on the stereo jack of the RPi
  • I plugged a USB MIDI keyboard on a USB keyboard of the RPi
  • No Ethernet cable connected, no screen (HDMI) connected, no USB flash drive connected (just using the default "Saw" built-in sound for the test), no additional DAC/sound card/RPi hat, no Wifi configuration
  • I plugged the power cord of the RPi
  • Wait 12 seconds
  • Play notes on the USB MIDI keyboard. It works: you can hear the "Saw" classical sound.

I did nothing else than these steps and all was working. Idem on RPi 3 B+.

Do you use a DAC? Which precise model of RPi (written on its PCB)? Which USB MIDI keyboard? Ethernet plugged or not? Wifi enabled or not?
Can you write down every step you did? (even little steps that might seem not important: the devil is in the details :))

See you

Jo

A
Arthur posted Dec 6 '21, 19:19:

Hi Jo,
Thank you for the fast snswer.
In your test i miss the step where you saved the WAV samples to your SD-Card. In which file system should the card be formatted with? NTFS?
Or do you do the test without WAV samples from the SD-Card?
Best Regards
Arthur

A
Arthur posted Dec 6 '21, 19:37:

Hi Jo,
Here are the answers:

Do you use a DAC? No
Which precise model of RPi: Pi3b+ and PI4
USB MIDI keyboard: USB Miditech Midistart 3 Pro
Ethernet plugged: Yes

Note: when booting, I get about six error messages: [FAILED] Failed to start Load/Save RF Kill Switch Status

Best Regards
Arthur

J
Joseph posted Dec 7 '21, 09:40:

Hi Arthur
Thanks
Can you retry with something identical to the step-by-step test I posted above? (I edited it to add more details)

i.e. no Ethernet cable connected, no screen (HDMI) connected, no USB flash drive connected (just using the default "Saw" built-in sound for the test), no DAC, no Wifi configuration.

All the best
Jo

A
Arthur posted Dec 7 '21, 16:25:

Hi Jo,
yes as I wrote i can hear the default "Saw" built-in sound after 12 seconds but my problem is that i can't hear Sound-Samples from USB SD-CARD.
Can you make the same Test with Sound-Samples from USB SD-CARD?
Best Regards
Arthur

A
Arthur posted Dec 7 '21, 21:20:

Hi Jo,
I found the problem. My power supply was too weak! After I connected the RPi HIFI AMP with more voltage today, the samples are loaded correctly!
However, I haven't been able to successfully install the HIFI AMP yet, but that's another topic ...
Best Regards
Arthur

C
Conrad posted Jan 9, 14:08:

Hi Arthur, I had the same problem, but I don't have any voltage issues. I have a Pi4 as well, but it won't load the samples. I did get it to work once with the piano. It randomly worked but I could not get it to do it again. How is yours going?

...

  (not published)
  I want to post as guest
 

Post