remount system rw: can't find / in fstab

Nik posted Mar 6 '17, 23:38:

Hello guys,
I'm experimenting with SamplerBox and I think it's great. There is one problem though that keeps haunting me over and over again: At first, the command "mount -o remount,rw /" usually works and I can mount the filesystem writable to change stuff. But at some point, I'm getting the error message "can't find / in fstab" and I can't remount the filesystem anymore, therefore not change anything anymore.
I've read a lot about it, and all threads I found in Linux forums pretty much say that there's something missing in my fstab. As I can't edit my fstab (read-only filesystem), my only option at this point is to sweep the SD card with the original image and start from scratch.

Now, I'm sure that:

  • I did never delete anything in my fstab.
  • I see only one line in fstab on the fresh image (opening with "nano fstab") which mounts my Sample USB drive
  • The error message occured to me at least once BEFORE even mounting the filesystem once as writable.
  • My mtab shows the USB stick as the only mounted drive. No SD card with root filesystem (I don't know if that's normal).
  • blkid shows a "ROOT" labelled device at / that cannot be unmounted (probably my filesystem?)

Does anyone have an idea what I can do about this? Any help is much appreciated.
And Joseph, thanks for the great project.
Best regards, Nik

Nik posted Mar 9 '17, 15:35:

No one? :(

Gabor Kita posted Mar 22 '17, 09:54:

Hi Nik!


mount /dev/mmcblk0p1 /boot
mount -o remount,rw /dev/mmcblk0p2 /

Nik posted Mar 29 '17, 01:43:

Hi Gabor,

thanks for you reply! I came up with a solution that worked for me a while ago. Just in case someone has the same problem: I've added the root path (/) to fstab. This solved the problem for me, although it was never in there. The problem doesn't come up anymore.
This is the line I added:
UUID=<myDeviceUuid> / vfat defaults,rw 0 1

My last resort would have been to mount the whole thing as writeable by changing the parameter in cmdline.txt on the boot partition, but fortunately, I didn't have to try that out.

So anyway, thanks a lot! Now we have three possible ways to approach this issue.
Kind regards


  (not published)
  I want to post as guest