Samples on USB stick does not work

Cedric posted May 6 '17, 12:10:


I have setup Samplerbox in "light" version : Raspberry Pi 3 only.
First, I have successfully loaded the boot image on the micro-SD card, plug my Midi keyboard (M-Audio Axiom mini Air-32) and my headset.
That works great with the default samples.

Next, I downloaded other samples from this websites and copied them to a USB stick respecting the folder tree as recommended in the FAQ .
I plugged the USB stick into the Raspberry Pi and rebooted it.
From here, I did not get any sound.

Do you have an idea of what is going wrong ?

John posted May 9 '17, 14:00:

pls clarify, What are your folder and sub folder names?

Cedric posted Jun 7 '17, 22:07:

My USB stick tree is the following :

/1 Flute2
/2 LatelyBass

Each folder has its own WAV files, bank of sounds downloaded from
I have tried with different USB sticks, same issue.

I only get the default bank sound included in the default samplerbox package installed on the SDCard connected into my Raspberry.

Of course, for the moment I have got no button to switch from a folder to another (buttons + and -), but using an USB stick should make my Samplerbox using at least what is in the folder /1 of the USB stick, right ?

I am still looking for a solution.

AlexM posted Jun 8 '17, 05:06:

Hi Cedric,

Sounds like the script isn't looking for your USB stick. You will need to edit line 18 of the file to:

SAMPLES_DIR = "/media/" 

FYI the next release will remove the need to edit this file and will auto-detect a connected USB stick :)

Cedric posted Jun 8 '17, 08:52:


the setting SAMPLE_DIR in is already present and correctly configured (I did not do anything, it was included in the package).
Anyway, being on CLI, I plugged the current USB stick again and I get an error message and I see nothing under Media folder.
Now I am using another USB stick and I can see its content under /Media (folders corresponding to the instruments with a number at the beginning of the title).

Now, how can I use these instruments considering that I have not yet buttons plugged into the GPIO pins ? It seems my MIDI keyboard does not have anything to do this.

Thank you very much.

P.J.L. Cuijpers posted Jul 11 '17, 19:27:

Having the same problem here. Is it a matter of properly formatting the USB first?

HansEhv posted Jul 11 '17, 23:26:

In samplerbox samples are loaded from the USB interface device SDA1. USB sticks however don't always have a partition table and in that case the filesystem should be mounted from SDA. You can check your situation with the "lsblk" command. Here's the /etc/fstab line for resolving the SDA issue:

/dev/sda /media auto ro,nofail 0 0

See also discussion on

AlexM posted Oct 9 '17, 07:22:

Hey guys - I ran into an issue with one of my USB sticks. It was formatted as exFAT instead of the required FAT32 and hence not found by my RPi. All we needed to do was install a package that enables support for exFAT filesystems:

mount -o remount,rw / # remount main partition as read-write
apt-get -y install exfat-fuse # install exFAT support driver
Rajiv Deo posted Oct 10 '17, 13:20:

I found that there should be no spaces or line return in the definition file, otherwise it does not load.

H3rv3 posted Oct 11 '17, 19:33:

Try folder 0 if you don't have the buttons.
Had this issue and found that the folders start at 0 (check

Eric posted Oct 11 '17, 19:54:

Can you specify? So I can just name a folder "0 Flute" on my USB, and it should automatically run that, when I turn it on with the usb plugged in?

Fabi posted Jul 29 '19, 22:26:

I know this is an old post but I seem to have the same problem as OP. Initial sound works fine but when using a USB Stick with a downloaded sample (0 GrandPiano) it does not play anything. Tried 2 differen USB Sticks with same result. It shows some no DMA platform data message on screen..

HansEhv posted Jul 30 '19, 23:51:

Samples are loaded from the USB interface device SDA1. USB sticks however don't always have a partition table and in that case the filesystem should be mounted from SDA. You can check your situation with the "lsblk" command. You can change this behaviour in the /etc/fstab. Discussion in gives more detail.

Fabi posted Jul 31 '19, 21:54:

Thanks for your reply!
It actually seems to be correct lsblk returns this:
`-sda1 ... part /media/

Nevertheless, I have tried changing /etc/fstab to use /dev/sda instead of /dev/sda1 and it does not work either..

Any other ideas?

HansEhv posted Aug 4 '19, 21:50:

Well, next thing is contents. Does /media show '0 piano' etcetera. Next after that: what does en show wheb started manually (stop the autostarted one with 'systemctl stop samplerbox' first). In other words, local debugging to get more info than just 'it doesn't work'.
Because it works... Usually :-)

Adam posted Sep 8 '19, 17:06:

Having the same troubles. Going to try formatting my USB a few different ways and then if that don’t work I will hook up my keyboard and screen and check out the py files

Adam posted Sep 8 '19, 19:51:

I have a 7 segment screen. When I turn on it shows L000 and then changes to 0000 and the default sound works fine. When I push the button it changes to E001, E002 etc but I’m getting no sound.

Adam posted Sep 8 '19, 20:41:

Can someone tell me the command to turn off the read/write

HansEhv posted Sep 9 '19, 00:00:

You only have the sample set "0 Saw". When you start the box it loads set 0 (L000, L meaning load) and when ready, you have 0000 (meaning 0).
When you push the button you ask to load set 1, but this is not present, so it results in E001 (Empty 001). As simple as that.
Read/write is turned off at startup.

Adam posted Sep 9 '19, 08:30:

Yeah but I want to turn on read write so I can have a look under the hood. I’m guessing I need to turn it off again after?

I thought it meant empty. Back to the drawing board. Come on you usb!!!

Adam posted Sep 9 '19, 09:06:

I got you know there’s a script to turn off read write at startup. Time to figure this out

HansEhv posted Sep 9 '19, 12:10:

Standard mount command with option (-o) ro or rw. It's shown in the motd when you login to the commandline.
Mounting ro is indeed somewhere in the startup, but why search for single commands which are basic Linux?

Adam posted Sep 9 '19, 13:20:

Ive managed to get my samples loaded now but but now i have a new problem. When i hold a some keys i get sound for a few seconds then it freezes. I cant change track and no more sound.
Could it be my USB is too slow at data transfer? Maybe its my Pi, im using a zero...

Ukranio posted May 2 '20, 22:49:

In my case did not detect the USB because I had it formatted with blocks of 8KB, I formatted it in Windows with a block size of 4KB and it works perfect!

ryanphs99 posted Aug 25 '21, 23:59:

Ok, so this is literally killing me, so I'm hoping someone can ease my pain...

Using a Rasp. Pi 3 with the standard .img file from samplerbox.

I'm having the same issue as OP. I just can't seem to get any samples to load (I can get the default sound though).

I have a FAT32 formatted USB drive (tried 3 different usb drives actually, same behaviour on all 3) with various sample packs downloaded from samplerbox's site, so I'm guessing the definitions file and .wav naming lexicons are correct.

Anyway, I read through this thread and as suggested, ran lsblk. Results below:

sda 8:0 1 930M 0 disk
└─sda1 8:1 1 925.5M 0 part /media

I tried to change /etc/fstab to use /dev/sda1 instead of /dev/sda. After changing this I can now see all my files in the /media directory using cd /media ls -l.
Sidenote* when /etc/fstab uses sda, nothing appears in /media (so I'm guessing that changing /etc/fstab to sda1 is the way to go?)

Anyway, in an effort to get it to load something else, in I tried changing:

preset = 0
preset = 1

...but this still had no effect.

I'm confident with python (so am willing to debug this) but am fairly new to the rasp. pi. platform and my linux knowledge is ok, but not great.

I'm now trying to put in breakpoints/print stuff in the code. I can see that on line 260 there is a function called ActuallyLoad() which appears to be the main function for looking up directories of samples and loading them into a set called: samples = {}.

With this in mind I want to print out the contents of this set to check whether or not it's attempting to load in any of my samples, but I have no idea where this prints to?

For reference I have my Pi linked up to a monitor via HDMI and I'm using SSH as well.

Is there a debug mode that I need to use when trying to do something like this on a Pi?

Enlightened ones of linux and all things Pi! Please hear my call! I'd happily start debugging this if I get some pointers...

gmeader posted Aug 26 '21, 04:40:
  1. try a newer image from here at
  2. Try stopping the running (systemctl stop samplerbox) and Starting the script by hand to see the informational and error messages:

cd SamplerBox

ryanphs99 posted Aug 26 '21, 11:18:

So yeah, I used the newer image from and boom, all of my issues are now fixed (thanks to another post on this forum).

I know this thread is super out of date, but they really should update the site to host the newer .img files, or at least link to them...

Ecisan posted Dec 9 '21, 13:53:

I managed to run Samplerbox on a Raspberry pi 3 B +, although I have no knowledge of Linux. I first plugged the USB sound card (Behringer UCA 202) into the Raspberry pi, and then installed the Raspbyan (Raspberry Pi OS 32 bit) according to the instructions in the video from the Youtube channel. The video is titled: "How to use Raspberry Pi Imager | Install Raspberry Pi OS to your Raspberry Pi (Raspbian)". The sound only went over HDMI on my TV. I chose the sound card according to the instructions in this vide on "Pury perfection" Youtube chanell, The video is titled : "How to get audio output on raspberry pi 3 model b+ headphone and HDMI config". Then I installed the Samplerbox software. The USB memory stick didn't work so I copied the samples to another microSD card. I plugged it into the Rspberry via a USB card reader. And here it works.


  (not published)
  I want to post as guest