USB stick problems

Jakob posted May 13 '17, 13:26:

This is a noob question, but what do I need to do with a USB-stick with samples in terms of formatting etc to get it to work? I got the samperboxworking fine, I can play the default sound with a usb-midi keyboard, no problem. I've tried just taking a thumb drive and adding directories with samples named /0 Somethingorother/, /1 Somethingelse/, etc, but to no avail. I'm really shit at this, so please use small words. I'm on a Raspberry Pi B original.

Thanks in advance for any insights.


Jakob posted May 13 '17, 13:28:

Oh, and by the way, I'm a mac user (through no fault of my own, mind you).

AlexM posted May 13 '17, 15:08:

How are your samples filenames named? And are you using an (optional) definition.txt file?

Jakob posted May 13 '17, 16:05:

I've been using the sample folders downloadable from, just to try to make it work first. The Mellotron sample is named 343_G2, 3444_G#2, etc. One of the Poly 61 sample directories contains files named just c1, c2, etc. In that folder there's a definition.txt (what is that, anyway?). I also found this bit of info: "the samplerbox build doesn't like GUID Partitioning Scheme. It detects a disk, and tries to mount it, but the mount point is empty. This means, on a Mac you can't use the GUI application "Disk Utility" to make your FAT32 disk, you need to do it via the command line." Might that be the problem?

Thanks a bunch for answering.

Jakob posted May 13 '17, 19:12:

Update: I've formatted the thumb drive from the terminal. Still nothing.

AlexM posted May 14 '17, 10:59:

The definition.txt file is described at point 6) in the FAQ:

What kind of MIDI keyboard are you using? The Mellotron samples start from G2, so if it's a small keyboard maybe you have to set the octave higher on your keyboard to reach the samples.

I wouldn't have thought your USB disk format would be an issue - but I can't test it myself (Windows)

Jakob posted May 14 '17, 11:33:

Thanks for answering again. I've a Keystation mini 32, and I'm in the C3 octave, so that shouldn't be an issue. The Mellotron sample pack aldready has a definition.txt, so that shouldn't be it either. I read somewhere that the Pi sometimes doesn't work with old and/or crappy thumb drives, so I might try to buy a couple of new ones and see what happens. But that really feels like a hail mary...

AlexM posted May 14 '17, 12:40:

Have you named your Mellotron folder "0 Mellotron"? If so, does the "0 Saw" sample-set work on your USB drive?

Jakob posted May 16 '17, 12:44:

Hi again and thanks for your patience and help. I went and bought a couple of thumb drives this morning and did exactly what I did with the old one. AND IT WORKS NOW. (It's a 8GB Kingston DataTraveler 50, in case someone has the same problem as me.) Hell yeah!

AlexM posted May 16 '17, 14:03:

Thanks for the update! What make was your old one?

Jakob posted May 17 '17, 15:11:

It was an old Sandisk Cruzer. I think the problem might have been the pesky U3 virtual drive. Tried to uninstall it from a friend's PC (the U3 software is, of course, not Mac compatible), but the uninstaller broke down repeatedly. Might just have been that the thumb drive was way old, abused and corrupted...

rainless posted Dec 8 '17, 04:31:

I'm having the same problem with a sandisk cruzr. Guess I'll have to try another stick... though I also had the problem with an SD card plugged into a card reader...

Ted posted Dec 25 '17, 22:06:

You should be able to use MBR in disk utility, though I would have thought samplerbox would prefer GPT, being based on linux and all... You have to erase, not partition, the disk to change its partition scheme. If that doesn't help, you can format the stick from within samplerbox using fdisk to create a new dos (fat) partition map. I suspect the problem is that you have a thumb drive bigger than 2gb, so when you partition it using GPT in disk utility, the first partition will be an EFI system partition, when samplerbox expects the first (and only) partition to be the one with sample files in it.

Thomas posted Feb 24 '19, 07:58:

Hi everybody

All work Well from midi and sounds.

Just but my wireless don't work (Wifi) and keyboard layout is still US or GB I want his french.



  (not published)
  I want to post as guest