Serial midi error

Berry posted Jul 14 '17, 21:28:

After some troubles setting everything up, I'm finally getting some sound using serial midi.
But after just a couple of seconds I get this error:

Opened audio device #2
Preset loading: 0 (0 Saw)
Preset loaded: 0
Exception in thread Thread-1:
Traceback (most recent call last):
File "/usr/lib/python2.7/", line 810, in __bootstrap_inner
File "/usr/lib/python2.7/", line 763, in run*self.args, **self.__kwargs)
File "", line 445, in MidiSerialCallback
data = ord( # read a byte
File "/usr/lib/python2.7/dist-packages/serial/", line 460, in read
raise SerialException('device reports readiness to read but returned no data (device disconnected?)')
SerialException: device reports readiness to read but returned no data (device disconnected?)

I'm kind of out of my depth with the error message and hope someone can guide me in the right direction.
I have done the manual install and added enable_uart=1 and dtoverlay=midi-uart0 to /boot/config.txt
That's all I've changed. I've tried with a Korg Padkontrol and a Microkorg with the same result.
Using the usb connection works fine.

Berry posted Jul 14 '17, 21:54:

Oh, and I'm using a 2b.

Berry posted Jul 20 '17, 18:45:

Seems like I found the problem. I disabled login shell over serial and so far it's working great.


  (not published)
  I want to post as guest