spent hours troubleshooting with no luck, looking for a solution to default patch loaded

Eric posted Oct 11 '17, 02:51:

Hey yall, I've tried at least a hundred times to get the samplerbox to load something other than the default saw on startup, to no avail. I've tried loading samples on 3 different USBs but it ignores them and just loads the saw wave. I've tried putting sample on the root folder, but it doesn't care. I've tried deleting the saw from the root folder, putting in another sample pack, naming it "0 saw", and I just dont get any sound after that. Does anyone know how to make this thing load anything other than the saw? Thanks!

AlexM posted Oct 11 '17, 08:55:

Can you check to see what format your USB sticks have? Should be FAT32.

Eric posted Oct 11 '17, 20:05:

Just reformatted them both to make sure, yup they're both FAT32. No matter what I do now, I get no sound (I assume this is because I deleted the saw from the root folder, hoping it would force itself to recognize the samples on my USB, but that didn't happen)

AlexM posted Oct 12 '17, 03:13:

In your console can you see if you can access the USB stick:

cd /media

ls # let's see if any directories are listed

You can also check to see if the stick is actually recognised by your RPi:

lsblk # list block devices

You should see something like this:

sda           8:0    1 14.4G  0 disk
`-sda1        8:1    1 14.4G  0 part /media
Eric posted Oct 12 '17, 19:39:

Yup, ls displays the 2 directories I have in the USB ("0 Box" and "1 Organ" for testing purposes), it just doesn't play any sound, so I'm assuming it isn't loading the samples

AlexM posted Oct 13 '17, 01:49:

Have you checked the SAMPLES_DIR variable in samplerbox.py points to your USB stick? ie SAMPLES_DIR = "/media" (default is "." which is problematic)

Eric posted Oct 13 '17, 06:14:

How do I check that? I'm using the .iso quick start image, is it possible to edit the .py file from within the pi?

AlexM posted Oct 13 '17, 07:28:

Yes it is :)

First remount the SD card as read-write:

mount -o remount,rw /

Now edit the samplerbox.py file:

nano SamplerBox/samplerbox.py

Find the SAMPLES_DIR line and change it to '/media'. When you're done, ctrl-X and y to save.

reboot to reboot the system

Eric posted Oct 16 '17, 22:03:

No dice on that one-- it was already set to /media/

HansEhv posted Oct 16 '17, 22:29:

So what's in the two directories:

Do they contain the sample files named as indicated in the definition.txt (if no such file is present, default name is midinote.wav, midinotes being a number 0-127). Playable notes are around middle-c, which means "48.wav" or "60.wav", depending on middle-c being C3 or C4.

Are the sound files wav files with a sample rate of 44,1kHz and bitrate 24 or less.

Eric posted Oct 16 '17, 22:49:

on the mellotron sample (downloaded from the main page), I have numbers from 343-377, all the definition.txt says is *_%notename.wav

I've tried going up and down several octaves to make sure that is the issue and it didn't seem to change anything, though it's possible I didn't go up far enough?

Yup, samples are all 44,1 khz

HansEhv posted Oct 16 '17, 23:04:

OK, then go back to unanswered question from Alex: perform command: ....
.....and check the output (see his examples october 12 03:13)

Robert posted Oct 21 '17, 23:25:

I found formatting the usb drive to ext4 helps when fat32 isnt working properly, especially Sandoval drives :)

Eric posted Oct 24 '17, 22:06:

Have been busy and unable to get to my pi setup the past few weeks, I appreciate the continued help and will try to try the lsblk solution as soon as I get home

Eric posted Nov 2 '17, 23:22:

OK! I tried the lsblk thing, it lists:

sda1 mmcblk0 |-mmcblk0p1 -mmcblk0p2

still no sound at all when connected, I'm assuming since it isn't loading the saw (I deleted it to try and force it to play something else) it just plays silence

AlexM posted Nov 3 '17, 00:35:

Is it still true that you're only getting sound from the 0 Saw preset? If you are, what happens when you rename 0 Saw to 0 Saw2?

And if you remove the USB stick and reboot, will 0 Saw play? (0 Saw is also in the SamplerBox directory on the SD card)

You've mentioned before that you have been able to get sound out of your RPi, so that says to me the problem lies elsewhere.

Eric posted Nov 3 '17, 05:31:

I was previously getting sound, ONLY the saw preset-- I then removed the saw folder from the root of the SD card in the hopes it would default to something else, and now it plays no sound at all no matter what, I assume because the thing it wants to load isn't there anymore

AlexM posted Nov 3 '17, 09:32:

The Saw directory being absent from the root won't have any affect on the use of a USB stick. I still suspect it has something to do with your USB stick.

Can you see if there is a line for your USB (sda1) in fstab? nano /etc/fstab

Ted posted Dec 25 '17, 22:30:

You could stop the samplerbox service (#service samplerbox stop) and run it from the command line (/root/SamplerBox root# python samplerbox.py &) to view any stderr/stdout from samplerbox in your tty. should give you some pointers as to what is going wrong.

Also be aware that samplerbox has middle c midi note 60 (0x3C) hard coded as C3, not C4, the one sample set I downloaded (1 GrandPiano) was defined with middle C C4, confounded me for a while why lower notes weren't playing on 88-key keyboards until I had to go through the code.


  (not published)
  I want to post as guest