No files in media

Felipe Guajardo posted Dec 3 '17, 14:14:

Dear SamplerBox community, first of all, thanks a lot for this project it is a dream come true to me. I'm having a problem, I've connected 2 flash drives one of them just formatted and with some samples in it and the raspi doesn't find any directory in them.
I tried the line cd /media and then ls but it shows nothing. I also made sure that the flash drive is recognized doing the lsblk and it finds a device called sda with the size of my pen drive so I assume it is the pen drive. Is the problem caused because both of the drives I've tried are mp3 flash drives?

I'm using a M-audio oxygen61 and I'm getting the saw sound, it has the +/- buttons but it looks like they change parameters in the keyboard, like configurations and midi channel, could this be the cause of the problem? That the keyboard is not sending the +/- commands to the raspi?

Thanks a lot in advance.

Felipe Guajardo posted Dec 3 '17, 14:52:

I tried another MP3 and now it's working, i can access the samples. But I can't get the SamplerBox to play the samples. Is there any way to see what midi mesages my keyboard is sending?

Felipe Guajardo posted Dec 3 '17, 21:17:

I did make it work, non of the 3 flash drives that i tried before worked, when i checked with the lsblk command i noticed that the 3 faulty ones wouldn't have a mountpoint but the one that worked did have, does somebody knows whats causes this or what to look for when choosing a flash drive.

Glenn posted Dec 4 '17, 18:07:

You can see all the MIDI messages being received by the Samplerbox by setting this


in the config.ini, and running '''python''' from a console. I login via ssh (console/terminal and I give the following two commands:

systemctl stop samplerbox

so that I can see the messages that are displayed.

HansEhv posted Dec 4 '17, 21:37:

Hi Felipe,
In samplerbox samples are loaded from the USB interface device SDA1. USB sticks however don't always have a partition table and in that case the filesystem should be mounted from SDA. You can check your situation with the "lsblk" command. You can see and change this in /etc/fstab.
You can find a more in depth discussion in


  (not published)
  I want to post as guest