Samplerbox sees SDcard, doesn't see samples

David posted Apr 15 '18, 21:09:

I start my PI3B, login with root/root, I press a key(MAUDIO KeyStation61) and I can hear the default saw wave. I hit the button to go to the next sample and nothing (I'm not getting a console readout either, idk if I should) but if I hit the other button I can hear the default saw again. I've tried ls /media returning nothing and with lsblk I've identified my SDcard(in a micro/normal-sized reader) as drive SDB and partition SDB1. I've no experience with linux and samplerbox so I have no clue what to do. The samples are on a freshly formatted(FAT32) SDcard with only the samplerbox samples on them, sitting in their folders such as "1 GrandPiano".

David posted Apr 15 '18, 21:27:

Okay, I've learned a new command, YAY! I went into etc/fstab with nano to dicover one line that starts with SDA1, I tried to change it but it's read only. I've typed in mount -o remount , rw / but after a wall of text, fstab is still read only.

michael posted Apr 22 '18, 17:31:

Hi, David,

an experience I just made: raspberry 3 b 1.04: try to put some more (preset)-folders on the usb drive, if there is only one, rbpi seems not to be able to load it.

Alex posted Aug 27 '18, 10:54:

Turns out, it wants a drive with a partition, and expects the samples to be on the first one.

I first formatted the whole drive, and the system did not see my samples. Then I found this thread, saw "sda1" hint, and this solved the mystery.


  (not published)
  I want to post as guest