LCD 16x2 5V wont work

maxJ posted Oct 25 '19, 15:03:

I got some problems getting a lcd 16x2 5V to work with samplerbox.
First thing I did was putting the samplerbox 2 image on a sd card boots and works fine.
I tried different screens no succes I changed the pinout in the config files no succes.
At this point im not sure why this isnt working for me do I need a 3,3V screen?
Dont see anyone with this problem so far I got a 10k pot connected.
Im using a raspberry pi 2 model B do I need to run the adafruit lcd files first?

maxJ posted Oct 25 '19, 18:08:

I read at nickyspride website that he updated the gpio module im trying this asap

HansEhv posted Oct 26 '19, 00:57:

Well, Erik kinda uses the image as basis and uses the stick for loading extra SW. Please read his docs completely.
As he based his build on mine, you may also want to have a look at:
This has evolved since and has become quite complicated so it may not be your cup of tea, all up to you. Also pin usage is not 100% the same.
Both forks don't need the adafruit files. However it's both straight GPIO, not I2C which is default adafruit. So perhaps there is the issue..

max jong posted Oct 26 '19, 13:23:

I just bought a raspberry pi 2 and forgot about it got a lcd 16x2 used it alot so I know its working tried your build no succes tried nickyprides no succes im not using i2c btw I got it connected with jumperwires for now

max jong posted Oct 26 '19, 13:24:

I changed the gpio pinout in the config files but still no succes I got this pi straight out the box and never did any update etc

max jong posted Oct 26 '19, 17:01:

update I got 2 rows of blocks now instead of 1 row

max jong posted Oct 26 '19, 17:12:

nog een update ik heb het werkende met jou image bedankt voor de tijd

max jong posted Oct 26 '19, 20:44:

One question i got this lcd working the reason why it wasnt working was because of bad jumper wires. now I want to have the serial midi I connected a midi input circuit to pin 15 the RX but this isnt working is this the right pin? I enable midi serial in the config files.

HansEhv posted Oct 26 '19, 22:35:

Hi Max,
17:12: da's mooi, bedankt voor de terugkoppeling :-)

20:44: Below is for the homspace distribution only (!)
Pin15 is correct, you ran in to a bug as the current image has crippled serial midi handling.
The fix is on //

If you're familiar with GitHub, in plain English:

An update of of two files in /boot is necessary (or if access the SD from Windows: straight on the SD):

  1. Remove bcm2708.uart_clock=3000000 from cmdline.txt

  2. Remove from config.txt:

  3. Add to config.txt:
HansEhv posted Oct 26 '19, 22:39:

Oops "familiar"=>"unfamiliar"
And forgot two statements to add to config.txt too:


max jong posted Oct 27 '19, 12:34:

thanks for the help everything works as it is suppose to be.
TLDR check you jumper wires before testing.


  (not published)
  I want to post as guest