No sound and no error Roland Quad-Capture

Cristofaro posted Jan 13 '20, 19:16:

Hi everybody

I am fighting to get any audio out from my keyboard (M-Audio Keystation 61).
I have a Raspberry Pi 3B+ using the newest image from:

I have an USB drive with the Soundfont:

I stopped the service and initialised again and I got the message as follow:

root@samplerbox:~/SamplerBox# python
Started 16x2 LCD via GPIO: RegisterSelect=7, Enable=8 and Datalines=[27,17,18,4]
Available audio devices
0 bcm2835 ALSA: - (hw:0,0), ALSA (0 in, 2 out)
1 bcm2835 ALSA: IEC958/HDMI (hw:0,1), ALSA (0 in, 2 out)

2 QUAD-CAPTURE: USB Audio (hw:2,0), ALSA (6 in, 4 out)
3 sysdefault, ALSA (0 in, 128 out)
4 dmix, ALSA (0 in, 2 out)
< 5 default, ALSA (0 in, 2 out)
Opened audio device #2 on 44100Hz
Invalid mixer card id "1" or control "['PCM', 'Speaker', 'Headphone', 'Digital']" --
-- Mixer card id is "x" in "(hw:x,y)" (if present) in opened audio device.
Started buttons via GPIO: Increment=5, Decrement=13, Select=26
Open Keystation 61 20:0 as MIDI IN 1
Open Keystation 61 20:1 as MIDI IN 2
Starting httpd on port 80
We have None, we want 0 GrandPiano
Loaded '0 GrandPiano', 55% free memory left

Everything seems to load correctly but I get no sound. If I run the script to monitor the keys pressed in the keyboard I get the response.
I tried to change the MIDI channel from 1 to 2 or 3 but no sound.

I also tried using the RPi Audio jack without any success. So far no sound at all.
Here are pictures of the web server:

Anyone can help me please?
Thank you in advance

HansEhv posted Jan 13 '20, 22:08:

Hi Cristofaro,
If you use "python" instead of "./" you will also get the midi channel and the basic translation of the notes sent. Logic of capturing the midi input with that python is comparable with the way the samplerbox script does it's job.
It's the last thing to check before real debugging is at stake, as your log suggests everything is ok (the invalid mixer card id doesn't make any difference for the basic functioning ... unless the default volume of your DAC is 0 ofcourse, but I guess it isn't).
I haven't permission to see your pictures, but I'm afraid they won't add much value for this .. but every piece of info...
Regards, Hans

Cristofaro posted Jan 14 '20, 10:50:

Hi Hans

Thank you for your time and consideration.
I changed the permission to allow access to the folder, sorry for that.
I ran the python command as suggested, see below:

root@samplerbox:~# python
Open "0" as MIDI IN 1
Open "1" as MIDI IN 2
Open "0" as MIDI IN 3

"0" -> Channel 16, message 9
==> Note on 69=A4, velocity=90 (velocity=0 means note-off)

"0" -> Channel 16, message 9
==> Note on 69=A4, velocity=0 (velocity=0 means note-off)

"0" -> Channel 16, message 9
==> Note on 74=D5, velocity=75 (velocity=0 means note-off)

"0" -> Channel 16, message 9
==> Note on 74=D5, velocity=0 (velocity=0 means note-off)

I noticed that the Channel is 16, then I went back to the GUI in the web page and tried to change to CH 16, nothing changed.
See picture "dashboard 3 midi channel 16.png".

I checked the volume from the DAC and it is near the maximum. I also tried to use both head phones and the monitor I have from Yamaha, no sound on both.

I also uploaded the files "config.txt" and "configuration.txt" in case you need to double check.
I am not using GPIO nor LCD for now.

Do you have any other suggestion?
Best regards

Cristofaro posted Jan 14 '20, 11:02:

Hi Again, I don't know why the text became large above, if you can fix that...

One more comment about my attempt. I just connected the keyboard with Ableton live 10 lite and everything is working as it should. See the picture "Ableton live.png" in the same sharing location:


HansEhv posted Jan 14 '20, 23:10:

Hi Cristofaro,
I can't fix the text as this is Josephs' forum, not mine. I just built an alternative based on his creation.
It's a bit weird to use channel 16 as this is the system channel. But it doesn't matter, it should work anyway. To be absolutely sure I've reprogrammed my test setup to use 16 and it works as expected.
Your pictures just confirm what you said - conclusion is it should be working ok.
But it doesn't.
As stated this was the last thing to try before real debugging is at stake.
If you're willing to go for that, please contact me via the feedback tab on my site so I can start direct mail contact. Be prepared for a track requiring some linux skills and patience.

HansEhv posted Jan 14 '20, 23:13:

"my site": the homspace one :-)

Cristofaro posted Jan 16 '20, 20:56:

Hi Hans. Did you receive my e-mail? I used your contact form in your page :)

HansEhv posted Jan 16 '20, 22:14:

Sorry and yes, but I've a busy week. Please do expect answer, but later.

Cristofaro posted Jan 18 '20, 10:53:

No problem, just wanted to be sure that you got my message. Whenever you have some free time. Thanks a lot.


  (not published)
  I want to post as guest