Raspberry Pi 1 working config

S
Simon posted Apr 10, 02:40:

Dear friends,

to get this work on an old Pi 1, model B (don't know the revision), I had to change some things in the file /root/SamplerBox/samplerbox.py

!!! seems only 0 works for audio jack sound

AUDIO_DEVICE_ID = 0 # change this number to use another soundcard

maybe optional change: I didn't use USB for samples yet, instead I put the samples in /samples/

SAMPLES_DIR = "/samples/" # The root directory containing the sample-sets. Ex$

maybe optional change: I switched this of, because I didn't need it, yet

USE_SERIALPORT_MIDI = False # Set to True to enable MIDI IN via SerialPort (e.g. Raspbe$

!!! I2C was critical: If set to True SamplerBox failed!

USE_I2C_7SEGMENTDISPLAY = False # Set to True to use a 7-segment display via I2C

USE_BUTTONS = True # Set to True to use momentary buttons (connected to Raspber$

maybe optional change: lower for slower Pi

MAX_POLYPHONY = 30 # This can be set higher, but 80 is a safe value

Best regards,
Simon

S
Simon posted Apr 10, 02:41:

whoops didn't know hash changes the font size here :->

S
Simon posted Apr 10, 02:45:

edit: I didn't build up the whole samplerbox yet. Maybe the I2C error came from missing an I2C device? My hardware so far is just a Pi1, midi kb and speakers.

...

  (not published)
  I want to post as guest
 

Post